Env Help

Discussion in 'Gaming' started by psychosnoman, Aug 17, 2007.

  1. psychosnoman

    psychosnoman Well-Known Member

    Posts:
    150
    Likes Received:
    0
    Joined:
    Jan 25, 2006
    My env won't turn on. When I press the power button it will come up with the Verizon Wireless screen and stay that way. I've tried taking the battery out and putting it back in and plugging it up to the wall but I can't get it to turn on. Do you guys know how to make it work?
     
  2. Coolguy

    Coolguy Well-Known Member

    Age:
    113
    Posts:
    1,997
    Likes Received:
    0
    Joined:
    Jul 24, 2005
    Location:
    New York City
    Deos verizon use sim cards? if so, make sure its in properly. Check your manual, i THINK theres something called full reset where the phone will go back into factory settings. was it working before?
     
  3. Flag

    Flag Well-Known Member

    Posts:
    1,177
    Likes Received:
    0
    Joined:
    May 12, 2007
    Factory Reset like Coolguy said.
     
  4. fattony69

    fattony69 Member

    Posts:
    9
    Likes Received:
    0
    Joined:
    Mar 26, 2006
    I have had this problem. I took out my battery for about 5 minutes and put it back in. Then I restarted, but when it turned on, I connected my charger. It seemed like my phone was barely alive and couldn't get enough juice per say, to go any farther.
     
  5. Coolguy

    Coolguy Well-Known Member

    Age:
    113
    Posts:
    1,997
    Likes Received:
    0
    Joined:
    Jul 24, 2005
    Location:
    New York City
    Hmm, might be a bad battery, I would call verizon and tell them to do something about it :)
     
  6. psychosnoman

    psychosnoman Well-Known Member

    Posts:
    150
    Likes Received:
    0
    Joined:
    Jan 25, 2006
    Thanks for all the help guys. This phone is just screwy. I got it turned on last night about 5 minutes after i posted and hae decided just to leave it on. maybe I need to update it or something.
     

Share This Page