PDA

View Full Version : Mouse Problem


07.
12-12-2004, 10:03 PM
I have a logitech PS/2 Port mouse , and for some reason my left click doesnt work.I tried going to the options panel to fix the problem , but it still had no effect.I checked my usb port and everything and restarted , but still did nothing.I've had this mouse for about a year now and its given me no problem until a while ago , the left click suddenly stopped working. Any ideas of what i should do?

glitch
12-12-2004, 10:10 PM
buy a new one ;)

mttviper
12-12-2004, 11:15 PM
most likely its wearing out and you need to get a new either mouse or ps/2 port(cable) or one of the little spikes is bent. my suggestion

get a new one

07.
12-13-2004, 05:42 PM
I think Mouses cost cheaper , ill just get a new one then :)

Reminisce
12-13-2004, 08:55 PM
Something is prolly caught inbetween the button..maybe..that's how mine got messed up

07.
12-13-2004, 09:23 PM
I dont think so , my left click works perfectly , i think its just an inside problem..

Col_CDC
12-13-2004, 10:45 PM
lmao, mine left button broke when i was doing soemthing important :angry: but i got a new the next day :rolleyes:

Gez
12-14-2004, 12:43 PM
did you do anything to your comp eg. wipe it, delete some files

cos it maybe the drivers for it are corrupted try uninstalling them and reinstalling them again

07.
12-14-2004, 05:58 PM
nope , i havent deleted any files lately
but just incase , could someone give me the steps for reinstalling my mouse?

Gez
12-15-2004, 06:18 PM
they should come with the mouse but im guessin uv lost those, try the makers website

Tommykins
12-16-2004, 04:59 PM
i have no idea just listen to what those people said

playakilla
12-16-2004, 05:59 PM
juts buy a really cheap 5 dollar mouse

07.
12-16-2004, 06:10 PM
Cheap mouses dont last that long , im looking to buy a 20-40 dollar optical mouse
if i cant fix this one..

playakilla
12-16-2004, 06:20 PM
i just said buy a cheap one cuz i didnt know u had the mney to spend
buying the expensive one is allwasy the way to go

Halifax
12-16-2004, 06:48 PM
Maybe like my old mouse you've worn out the receptor in parts of that button. I had to click further up on the button to get it to work. Now I have a nice and blue Microsoft opti mouse ^^

07.
12-16-2004, 06:59 PM
Yea i think something is wrong with the parts , just now , i hit the click button as hard as i could and it messed up lol.. It used the right and left click button at the same time when i clicked on the left.. But then i slammed the mouse and it went back to the way it was lol..

dudeqz
12-21-2004, 12:13 PM
just buy a new computer